Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - norman

Pages: [1] 2 3 ... 18
1
This just shows a message on the map telling you to turn off internet explorer compatability mode. It is annoying but not harmful.

The only way to resolve this is to add registry keys in Windows using Regedit.

At two locations add a DWORD called iexplore.exe with a decimal content of 11000

HKLM\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

HKLM\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION

Right-click the key and select New > DWORD.

Give that DWORD the decimal value of 11000. This will make all sites render without compatibility view.

To prevent the notice coming up in a particular program add a DWORD in the same location as follows -

Zipsys - add ZIPSYS.exe with a decimal content of 11000
Loadmaster - add Loadmaster.exe with a decimal content of 11000
Sameday Express - add Same Day Express.exe with a decimal content of 11000

Norman
 ;)


2
General discussions / Office moving 01/07/2022
« on: May 11, 2022, 11:35:58 am »
Please note that on the 1st July, 2022 we will be changing our Registered Office address to :-

310 Wellingborough Road, Northampton NN1 4EP

Our contact emails and phone numbers will remain the same as now.

Our banking details will remain the same as well.

Norman
 ;)

3
Operational Status / Broadband down 11/05/2022
« on: May 11, 2022, 11:33:19 am »
The broadband went down this morning for a couple of hours (BT connection). It did not affect websites or emails as these are hosted elsewhere, just the Bulletin Board.

It just goes to show how we rely on the connection - probably too much.

All back to normal at 11.15am.

Norman
 ;)

4
Operational Status / Email and Website down 11/01/2022
« on: January 11, 2022, 11:50:23 am »
Our servers at Freeola are currently down due to a fault at the data centre main site. This affects our web sites and emails. It actually started with drop-outs at 7.45pm on 10/01/2022.

Was expected to be fixed by 12 mid-day 11/01/2022

3.45pm Still down

7.45pm Everything operational.

We were able to continue to receive and send emails all the time because we had set up 'relaying' using Outlook in a resilience exercise we performed some time ago.

Our main office systems are based on Windows and Linux servers that we maintain ourselves. We also use two distinct duplicated sites on different IP addresses, rather than rely on one.

Norman
 ;)

5
Miscellaneous / Let's Encrypt web site cert will not renew
« on: January 09, 2022, 08:00:04 pm »
On Linux to see certificates type -

sudo certbot certificates

To renew manually -

sudo certbot renew --force-renewal

If you just have one site try -

sudo certbot certonly --force-renew --cert-name sitename.com

Or more than one site -

sudo certbot --force-renew -d sitename1.com -d sitename2.com

And check .htaccess redirects http to https

Norman
 ;)

6
Sameday Express / Outlook - problem 'bounced' emails using SMTP
« on: December 21, 2021, 01:39:04 pm »
It seems that it is Microsoft is deliberately causing the 'bouncing' of a percentage of emails if using Microsoft Outlook under SMTP - all other email clients are currently unaffected. It is a security restriction that they have created to get Windows TLS email security pushed to a later version (TLS 1.2). Note that this ONLY affects the use of SMTP button and not the Outlook one.

"Exchange Online will begin rejecting a small (unspecified) percentage of attempts to make SMTP connections using TLS 1.0 or 1.1 and issue this error message -

421 4.7.66 TLS 1.0 and 1.1 are not supported. Please upgrade/update your client to support TLS 1.2. Visit https://aka.ms/smtp_auth_tls

This is a temporary error and clients can retry the connection. Exchange Online will block only a small percentage of connections it’s likely that the next attempt to connect will succeed. However, that small percentage of declined connections will increase over time to gradually make it more painful for clients using the older protocols to connect to Exchange Online. As Exchange Online declines more connections, clients will experience delays in transmitting email. In some cases, depending on the client’s error handling, email might not get through until someone updates the client to handle frequent retries (or upgrade the client to TLS 1.2."

The source code of the sent emails from Sameday Express indicate that they have ALL been sent under TLS 1.2

Until this annoying situation is resolved we suggest using ‘relaying’ to get around the issue.

We opened up a Google gmail account then linked our email address to it. We then used the gmail SMTP server settings instead of Outlook and not a single email ‘bounced’.

Other relaying systems should work as well, such as smtp2go.

See our PDF on how to use gmail in Downloads on our web site - Outlook_SMTP_TLS_1_2.pdf

Norman
 ;)

7
Loadmaster / Outlook - problem 'bounced' emails using SMTP
« on: December 21, 2021, 01:38:10 pm »
It seems that it is Microsoft is deliberately causing the 'bouncing' of a percentage of emails if using Microsoft Outlook under SMTP - all other email clients are currently unaffected. It is a security restriction that they have created to get Windows TLS email security pushed to a later version (TLS 1.2). Note that it ONLY affects the use of SMTP button and not the Outlook one.

"Exchange Online will begin rejecting a small (unspecified) percentage of attempts to make SMTP connections using TLS 1.0 or 1.1 and issue this error message -

421 4.7.66 TLS 1.0 and 1.1 are not supported. Please upgrade/update your client to support TLS 1.2. Visit https://aka.ms/smtp_auth_tls

This is a temporary error and clients can retry the connection. Exchange Online will block only a small percentage of connections it’s likely that the next attempt to connect will succeed. However, that small percentage of declined connections will increase over time to gradually make it more painful for clients using the older protocols to connect to Exchange Online. As Exchange Online declines more connections, clients will experience delays in transmitting email. In some cases, depending on the client’s error handling, email might not get through until someone updates the client to handle frequent retries (or upgrade the client to TLS 1.2."

The source code of the sent emails from Loadmaster indicate that they have ALL been sent under TLS 1.2

Until this annoying situation is resolved we suggest using ‘relaying’ to get around the issue.

We opened up a Google gmail account then linked our email address to it. We then used the gmail SMTP server settings instead of Outlook and not a single email ‘bounced’.

Other relaying systems should work as well, such as smtp2go.

See our PDF on how to use gmail in Downloads on our web site - Outlook_SMTP_TLS_1_2.pdf

Norman
 ;)

8
Miscellaneous / This network is blocking encrypted DNS traffic
« on: November 01, 2021, 11:40:11 am »
You may get this on iPad, iPhone or Android.

Solution - Delete your current wifi connection and then recreate it.

Norman
 ;)

9
Miscellaneous / Nuisance calls from 08456021111
« on: October 28, 2021, 10:02:12 pm »
We have started getting these.

It's BT. Text to speech convertor. Someone sends a text to your phone and this converts it to speech.

It can be a real nuisance and it can be spoofed. Call 0800-5875252 to stop it.

Norman
 ;)

10
Miscellaneous / Let's Encrypt web site security cert warning
« on: October 25, 2021, 09:02:12 am »
The root certificate that Let's Encrypt use for the certification path recently expired, meaning that security certificates that were issued using this are now displaying security warnings.

The answer is to force the renewal of the site certificate manually to use the new root certificate.

In a Linux terminal Window type -

certbot certificates

This will show the sites connected with the certificate.

Then try -

sudo certbot renew --force-renewal

or if you have one site -

sudo certbot certonly --force-renew --cert-name sitename.com

or more than one site -

sudo certbot certonly --force-renew -d sitename1.com -d sitename2.com

This should fix the issue.

Norman
 ;)

11
Raspberry Pi / Some index files failed to download
« on: October 19, 2021, 09:35:10 pm »
You get this message when performing apt-get update

Look in /etc/apt/sources.list

Alter mirrordirector.raspbian.org to legacy.raspbian.org

Norman
 ;)

12
Raspberry Pi / Pi useful terminal commands
« on: October 14, 2021, 09:51:51 am »
free -h checks memory
df -h checks disk space
ifconfig shows network setup
cat /proc/device-tree/model gives Pi model number
sudo hostnamectl set-hostname newname sets hostname

Norman
 ;)

13
Raspberry Pi / Booting Pi 3B from SSD
« on: October 14, 2021, 09:23:13 am »
I found a lot of instructions on the internet about how to do this but many were incomplete or were simply just wrong.

The only way I got it to work was to add these lines to config.txt on the existing SD Card :-

program_usb_boot_mode=1
program_usb_boot_timeout=1

Then reboot. This tells the Pi to check for other boot devices.

Once done, in terminal type vcgencmd otp_dump | grep 17:

The output should say 17:3020000a where the 3 indicates that USB boot is enabled.

Now plug the SSD into a computer and using the Raspberry Pi Imager create a new image on it.

Plug the SSD in and remove the SD card. Reboot. It should now work.

I tried to use the SD card copier to copy the SD card image onto the SSD and it didn't work. I kept getting 'Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2)'

Apparently if you have a Pi 3 (not the B) then you need to format a SD card and just put the file bootcode.bin onto it (available from Pi site). Then put this card in the SD card slot. This tells the Pi to boot from the SSD.

Norman
 ;)

14
"Application has failed to start because its side-by-side configuration is incorrect".

This has loomed up following a recent Windows update.

If you download a program from the internet then try to install it then you get a message similar to the above. It does not install anything.

It seems to be caused by a faulty Microsoft Visual C++ redistributable package. The quickest 'cure' is to go into Control Panel then Programs and Features then REMOVE ALL Microsoft Visual C++ redistributable packages.

Then - reinstall them all. I found a single source here - https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/

Norman
 ;)


15
Chromebooks / Problem trying to load Linux on Chromebook
« on: July 13, 2021, 06:01:36 pm »
If you have a new Chromebook and want to use Linux then you may have an issue. I had problems on my Asus C423 and had to research the issue as they didn't have an answer as to why it wouldn't load.

Found this on - https://www.androidpolice.com/2021/07/08/you-might-not-want-to-update-your-chromebook-to-the-latest-chrome-os-release-just-yet/

Google has pulled the latest version of Chrome OS 91. Reports have been emerging that some Chromebook owners are experiencing significant performance regressions on Chrome OS version 91.0.4472.147, the latest stable release. However, in the process of pausing the update on devices, Google has introduced another problem — you can no longer install Linux on what has now become the latest release again, version 91.0.4472.114.

After pulling the problematic update to version 91.0.4472.147, Google is now pointing to v91.0.4472.114 as the most recent stable release. However, it looks like the Linux installer app hasn't received the memo regarding the pulled update yet. As reported by Chrome Unboxed, the Linux installer checks if you're running the latest version of the OS before it runs, and it looks like Google's servers still claim that version x.114 isn't the latest anymore, prompting users to update their Chromebooks. Since version x.147 is no longer available, that's not possible — x.114 is simply the latest release now. Hence, you can't install Linux on the current release of Chrome OS 91 right now.


I had to tell Asus about this as they clearly didn't know.

UPDATE - THIS HAS NOW BEEN FIXED

Norman
 ;)

Pages: [1] 2 3 ... 18