Author Topic: Cannot choose my mapped drive as a data directory - red cross  (Read 261 times)

0 Members and 1 Guest are viewing this topic.

norman

  • Administrator
  • Full Member
  • *****
  • Posts: 210
    • View Profile
    • Zipzap Computers Limited
This is the effect of the User Account control (UAC) which was added in Windows Vista in 2006. When you map drives at logon, they are mapped with the filtered token (standard rights). When you now run an application elevated (with full admin token) it can't see the mapped drives of the normal permissions.

When network shares are mapped, they are linked to the current logon session for the current process access token. This means that if a user uses the command prompt (cmd.exe) together with the filtered access token to map a network share, the network share is not mapped for processes that run with the full administrator access token.

To allow admin programs to see the normal mapped drives, enable the setting EnableLinkedConnections

Click Start, type Regedit in the Start programs and files box, and then press ENTER.

Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.

Point to New, and then click DWORD Value.

Type EnableLinkedConnections and then press ENTER.

Right-click EnableLinkedConnections and then click Modify.

In the Value data box, type 1, and then click OK.

Exit Registry Editor, and then restart the computer.

Norman
 ;)